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1 Vor dem großen Sprung

OpenJUMP ist ein Geografisches Informationssystem, das ursprünglich von den kanadischen Firmen

Vivid Solutions und Refractions Research unter dem Namen JUMP entwickelt wurde. Der Name JUMP ist 

die Abkürzung für Unified Mapping Platform, das „J“ deutet auf die zugrunde liegende Programmiersprache 

„Java“  hin.  Das  „Open“  steht  für  „Open  Source“  (Quelloffen),  was  bedeutet,  dass  der  Quellcode  des 

Programms jedermann zugänglich ist.  OpenJUMP unterliegt  der  GNU General  Public  License und wird 

heute von Programmierern weltweit gepflegt und weiterentwickelt.

Die besonderen Merkmale von OpenJUMP sind: http://www.openjump.org/

• Vektor-basiertes GIS.

• Unterliegt der GNU General Public License.   http://www.gnu.org/licenses/licenses.html#GPL 

• Basiert auf offenen GIS Standards. http://www.opengeospatial.org/ 

• In Java geschrieben; Quelloffen (Open Source).

• Durch so genannte PlugIns erweiterbar.

• Einfach zu bedienende Editier-, Abfrage- und Analyse-Funktionen.

• Unterstützt mehrere Sprachen (Englisch, Französisch, Portugiesisch, Spanisch, Deutsch).

OpenJUMP bietet eine Fülle von Funktionen. Hier wird nur eine Auswahl vorgestellt. Die englischsprachige 

Version soll einen leichteren Einstieg in ergänzende englischsprachige Literatur ermöglichen.

Die hier gezeigten Beispiele beziehen sich auf eine kleine, künstliche Stadt  GeoCity, die am Schreibtisch 

entstanden ist (incl. Orthofoto, S.  36). Auch die Namen der Eigentümer der Gebäude und der Grundstücke 

sind frei erfunden und unterliegen nicht dem Datenschutz ;-)
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2 Die Anzeige - Komponenten von OpenJUMP

Nach dem Start von OpenJUMP erscheint die OpenJUMP Workbench mit einem leeren Projektfenster. Das 

Projektfenster ist aufgeteilt in eine Layer-Übersicht  (Layer List) und ein grafisches Fenster (Layer View), in 

dem die Layer dargestellt werden.  Layer (S. 28) sind Ebenen zur Darstellung von geografischen Objekten 

(Features). Ein Layer (Ebene) stellt im Allgemeinen ein spezielles geografisches Thema dar (z.B. Gewässer, 

Wälder, Häuser, Böden). 

Nach dem Start von OpenJUMP.

Ein Projekt (S. 40) ist die Zusammenfassung aller Layer.  Es können mehrere Projektfenster geöffnet sein. 

Über den Menüpunkt  Window kann zwischen den einzelnen Fenstern gewechselt werden. 

Ein neues Projekt wird über File>New>New Project (S. 40) erstellt. 

Ein bestehendes Projekt wird über File>OpenProject (S. 42) geöffnet.

Achtung: 

Jeder Layer muss in einer Datei oder Datenbank gesichert werden, erst dann kann das Projekt gesichert 

werden (siehe Kategorien und Layer, S.  28 oder Anbindung an eine PostgreSQL/PostGIS Datenbank, 

S. 75).
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2.1 Die Werkzeugleiste

Über  die   Werkzeugleiste (Tool  Bar)  können  Funktionen  wie  Zoom,  Pan  oder  der  Grafische  Editor 

angesprochen werden.

Werkzeugleiste (Tool Bar)

Neues Projekt Öffnen von Projekten und Dateien

Ausgewählte Layer sichern Zoom

Pan Zoom MausRad

Gesamtansicht Zoom auf markierte Items

Zoom dynamisch Zoom auf Auswahlrahmen 

Anzeige zurück Anzeige vor

Layerdarstellung ändern Attribute anzeigen und ändern

Markieren/Auswählen Markierung aufheben

Auswahlrahmen ziehen Feature-Informationen

Grafischer Editor Messen von Flächen und Längen

Rückgängig Wiederherstellen

Ausgabefenster                    SchnellZoom
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3 Geometrien

3.1 Allgemeines

Ein wesentlicher Bestandteil eines GIS sind die Geometriedaten und die Sachdaten. Die Frage ist, wie wir 

diese Daten in unser Projekt bekommen. Es gibt verschiedene Methoden, Geometriedaten in ein Projekt zu 

integrieren:

1. Durch  „freies  Zeichnen“  mit  dem  Grafischen  Editor.  Dies  ist  eine  sehr  einfache  Methode  und 

entspricht sicherlich nicht der gängigen Praxis (siehe „Der grafische Editor“, S. 11)

2. Durch Import von Dateien, die in einem bestimmten Format beschrieben sind. OpenJUMP unterstützt 

in der Grundversion folgende Formate:

a) Das JUMP GML Format (.jml), welches ein vereinfachtes GML-Format ist.

b) Das GML 2.0 Format.

c) Das WKT (Well Known Text) Format.

d) ESRI Shapefile.

3. Durch Digitalisierung von Rasterdaten, die direkt  eingelesen werden können, oder die ein  WMS-

Server liefert. 

4. Durch Laden einer Datenbanktabelle im PostGIS Format. Hierbei werden die Daten (Geometrie- und 

Sachdaten)  in  der  Objektrelationalen  Datenbank  PostgreSQL mit  einer  PostGIS Erweiterung 

abgelegt und können in OpenJUMP dargestellt werden (S. 75).

Digitalisierte Gebäude auf Rasterkarte (hier Orthofoto).
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OpenJUMP verfügt über einen einfachen grafischen Editor, mit dem man die Geometrien (räumliche Attribute)  

von geografischen Objekten (Features)  eingeben und editieren kann.  Es können die  Geometrien  Punkt 

(Point), Linienzug (Linestring) und Fläche (Polygon) erstellt und bearbeitet werden. 

Der grafische Editor wird mit dem Knopf        (Editing Toolbox) aus der Werkzeugleiste (Tool Bar) aufgerufen.  

Features werden auf einem Layer (S. 28) dargestellt. Mit RechtsKlick auf eine Kategorie (hier Working) und 

Add A New Layer, wird ein neuer Layer erzeugt. Natürlich kann auch auf bestehenden Layern gezeichnet 

werden, wenn sie editierbar (editable) sind.

        Einen neuen Layer hinzufügen.

Der neue Layer erhält  den Namen  New und ist  editierbar (editable).  Ist  ein Layer editierbar,  so wird der 

Layername rot dargestellt. Wird ein editierbarer Layer mit  LinksKlick markiert, erscheint der Name gelb und 

man  kann  auf  ihm  zeichnen  oder  bestehende  Geometrien  verändern.  Mit  dem   Menüpunkt  Editable 

(RechtsKlick auf den Layernamen)  kann der Editierstatus eines Layers geändert werden. 

Durch Links-DoppelKlick auf den Layernamen kann dieser umbenannt werden.
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3.2 Der Grafische Editor (Editing Toolbox)

Die Editing Toolbox stellt Werkzeuge zur Bearbeitung von Geometrien zur Verfügung:

    

     

          Editing Toolbox.

3.2.1 Options (Constraints)

Unter  der  Option  Constraints (Bedingung,  Einschränkung,  Zwang)  können  die  Bedingungen  festgelegt 

werden,  unter  denen  die  Features  gezeichnet  werden  können.  Hierzu  müssen  die  entsprechenden 

Funktionen unter   Bedingungen aus der Editing Tollbox angewählt werden (S. 22).

Length: Festgelegte Seitenlänge in Modelleinheiten 
(oder ein Vielfaches davon)

Incremental Angle: Winkelintervall (mit Shift aktivieren)

Angle: Fester Winkel relativ oder absolut 
(mit Shift aktivieren)

Bedingungs-Optionen.

HCU Hamburg, Geomatik, Uwe Dallüge 11

Markieren und Verschieben

Rechteck, Polygon, Linienzug und Punkt zeichnen 

Knoten einfügen, löschen und verschieben; Item scalieren

Knoten zusammenfassen; Linienzug teilen

Polygon, Linienzug, Kreis und Bogen unter Bedingungen zeichnen

Knoten nach Länge und Winkel verschieben; Drehung; 1 Item wählen; Kreis mit Radius und Auflösung

Teilstück aus Polygon; Polygon ergänzen; Bemerkungen, Polygon aus Linienzug
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3.2.2 Options (Dataset)

Ist Show charset selection gewählt, kann der Zeichensatz beim 

Öffnen eines Shapefiles gewählt werden.

 

                                                                                                                                                  Mit Next > zum nächsten Fenster.               

                     

                                   Der Zeichensatz für das Shapefile kann gewählt werden.
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3.2.3 Options (Measurement)

Unter Measurement können Optionen für die Darstellung zum Messen von Flächen und Längen           

eingestellt werden. Nach der Messung wird in der Kategorie System der Layer Measure angelegt, der das 

gemessene Polygon enthält.

Abstand und/oder Flächengröße anzeigen.

Abstand zwischen den Knoten anzeigen.

Knoten anzeigen.

Linien anzeigen.

Fläche füllen.

                                                                                      Knotenabstände, Summe der Abstände und Fläche vom Stadtpark.

HCU Hamburg, Geomatik, Uwe Dallüge 13



3 OpenJUMP 1.6 Tutorial   (Grundlagen)

3.2.4 Options (Selection Style)

Mit Selection Style kann die Farbe und die Knotendarstellung

der ausgewählten (selektierten) Geometrien verändert

werden.

3.2.5 Options (Snap / Grid)

Unter Snap / Grid kann unter anderem der Fangmodus (Snapping) und Gitterlinien (Grid Display) eingestellt 

werden. Es wird empfohlen, den Fangmodus auf Snap to vertices  (Auf Knoten fangen) einzustellen.

Tolerance: Fangradius in Pixel

Snap to vertices: Auf Knoten fangen

Snap to vertices and lines: Auf Knoten oder Linie fangen

Snap to grid: Auf Punkte vom Gitternetz (grid) fangen

Show grid: Gitternetz ein/aus. Size: Gitterabstand in Modelleinheiten

Show grid as dots: Gitternetz als Punkte darstellen

Show grid as lines: Gitternetz als Linien darstellen

                      

                             Fang- und Gitteroptionen.
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3.2.6 Options (Snap Vertices Tools)

Mit dieser Option können Punkte gefangen und als Knoten 

verwendet werden. Der Layer muss editierbar sein.

1. Das Polygon (blau) soll durch den

vorhandenen Punkt 1000 laufen.

2. Im Grafischen Editor das Tool 

"Snap Vertices Tool" auswählen

3. Mit LinksDruck einen Rahmen um die

Seite und den Punkt ziehen und loslassen.
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3.2.7 Options (View / Edit)

Unter der Option View / Edit kann eingestellt werden, ob während des Digitalisierens auf gültige Geometrien 

geprüft werden soll. Es wird dann z.B. geprüft, ob die Geometrie sich selbst überschneidet (Self-intersection) 

und das Feature wird nicht gezeichnet, wenn keine gültige Geometrie vorliegt.

                              

                           View / Edit Option.

 Fehlerhafte Geometrie (kein gültiges Polygon).
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3.3 Features zeichnen

Features sind abstrahierte Objekte der realen Welt. Zum Beispiel werden Straßen als Linienzüge, Gebäude 

als Flächen oder Bäume als Punkte abstrahiert und dargestellt.

In OpenJUMP hat jedes Feature ein räumliches Attribut (Geometrie) und kein oder mehrere nicht-räumliche 

Attribute (non-spatial attributs, Fachdaten, Sachdaten) z.B. Straßenname, Eigentümer, Baumhöhe.

Es können drei verschiedene Features gezeichnet werden:

 Punkt (Point),   Linienzug (Linestring)  und   Fläche (Polygon)  

Nach Auswahl des Geometrietyps wird mit LinksKlick die Grafik gezeichnet. Linienzüge und Flächen werden 

mit einem  Doppel-LinksKlick  beendet.

3.3.1 Punkt (Point)  

• Neuen Layer erstellen oder bestehenden Layer markieren und editierbar machen.

•         Die Editing Toolbox aufrufen.

•         Draw Point Tool drücken.  

• Mit LinksKlick Punkte im Grafikfenster zeichnen

3.3.2 Linienzug (Linestring)  

• Neuen Layer erstellen oder bestehenden Layer markieren und editierbar machen.

•        Die Editing Toolbox aufrufen.

•        Draw Linestring drücken.

• Mit LinksKlick Linienzug zeichnen.

• Mit Doppel-LinksKlick beenden.

3.3.3 Fläche (Polygon)  

• Neuen Layer erstellen oder bestehenden Layer markieren und editierbar machen.

•         Die Editing Toolbox aufrufen. 

•         Draw Polygon Tool drücken. 

• Den Anfangspunkt mit LinksKlick im Grafikfenster markieren.

• Weitere Punkte mit Linksklick hinzufügen.

• Mit Doppel-LinksKlick beenden.
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3.3.4 Zeichnen eines „Lochs“ in einem Polygon

• Layer markieren und editierbar machen.

•         Bestehendes Polygon selektieren.

• Die   Editing Toolbox aufrufen. 

•          Polygon bzw. Loch zeichnen.

•         Select Features Tool aufrufen. 

• Außerhalb des Polygons ins Grafikfenster klicken,

damit die Markierung aufgehoben wird.

• Oder mit dem Create Cookie Cut Tool 

 

                                                                              Polygon mit  „Löcher“.

3.3.5 Polygon ausschneiden

Polygon abschneiden oder ausschneiden. Hiermit kann z.B. auch ein Loch aus einem

Polygon herausgeschnitten werden (Siehe 3.3.4).

3.3.6 Polygon anpassen  

Neues Polygon an bestehendes Polygon anpassen.

3.3.7 Polygon aus geschlossenem Linienzug 

Liegt ein geschlossener Linienzug vor, kann mit          aus dem Linienzug ein Polygon gemacht 

werden. Der Linienzug bleibt erhalten.
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3.3.8 Kreis mit Radius und Genauigkeit zeichnen  

Mit der Funktion Draw circle with given radius and center kann ein Kreis mit vorher eingestelltem Radius 

und  Genauigkeit  (Accuracy)  gezeichnet  werden.  Hierbei  kann  der  Mittelpunkt  auf  einen  anderen  Punkt 

gefangen werden. Der Radius und die Genauigkeit kann durch Doppelklick auf den Knopf           eingestellt  

werden. Je kleiner die Zahl bei Circle Accuracy ist, desto genauer wird der Kreis gezeichnet.

Einstellungen durch Doppelklick auf 

Hinweis: Das Zeichnen der Kreise wird hier nicht durch Doppelklick beendet, sondern durch Auswahl einer 

Funktion aus der Editing Toolbox!
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3.3.9 Tipps

Es ist sinnvoll, jeden Geometrietyp (Point, Linestring, Polygon) auf einem extra Layer zu zeichnen (siehe auch 

Kategorien und Layer,  S.  28).  Jeder  Layer bekommt  eine vom Programm  zugewiesene Farbe,  die  mit 

Change Styles    geändert werden kann (siehe auch Layerdarstellung (Styles), S. 46).

Punkte, Linienzüge und Polygone auf unterschiedlichen Layern.

Hinweis! Während der Digitalisierung zoomen oder verschieben:

1. Alt Taste = Zoom 

2. Alt + Shift Tasten = Pan

Siehe auch Help>Shortcut keys...
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3.3.9.1 Shortcut keys (Help> Shortcut Keys...)
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3.4 Features unter  Bedingungen (Constraints) zeichnen

Flächen (Polygon), Linienzüge (Linestring), Kreise (Circle) und Bögen (Arc), können unter Bedingungen 

(Constraints)  gezeichnet werden (z.B. festgelegte Seitenlänge oder Winkelintervalle). 

Die Bedingungen werden in der Editing Toolbox          unter Options>Constraints festgelegt. 

Im linken Bereich der Statuszeile der Workbench 

(untere Zeile des OpenJUMP Fensters) läuft die 

Länge und der Winkel beim Zeichnen mit.

Länge und Winkel laufen mit.

3.4.1 Constraints>Length

Hierbei kann eine feste Länge in Zeicheneinheiten festgelegt werden. Ist z.B. eine Zeicheneinheit = 1 m, so  

werden nach der unteren Einstellung z.B. Linienzüge mit 10 m Seitenlänge gezeichnet.

• Länge in Zeicheneinheiten (model units) festlegen.

•         Draw Constrained LineString wählen.

• Linienzug zeichnen.

Hinweis: Funktioniert auch für

Constrained Polygon, 

Constrained Circle und Constrained Arc.

                                                                                                      Länge in Zeicheneinheiten festlegen.

3.4.2 Constraints>Incremental Angle

Sollen z.B. rechtwinklige Polygone gezeichnet werden (z.B. Digitalisierung von Gebäuden), muss die 

Schrittweite des Winkels auf 90 grad, also ein Vollkreis von 360 grad in 4 Teile (parts) geteilt werden.

• Teiler eingeben (hier 4).

•        Draw Constrained Polygon wählen. 

• Mit Shift + LinksKlick Polygon zeichnen.

• Mit Strg + LinksKlick Polygon schließen.

    Rechtwinklige Gebäude digitalisieren.            Einen Vollkreis in 4 Teile teilen.
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3.4.3 Constraints>Angle

Bei Constrain to relative angle  wird der Winkel

linksläufig zur gedachten Verlängerung der gezeichneten

Seite gesetzt.

Bei Constrain to absolute angle wird der Winkel

linksläufig zur gedachten x-Achse gesetzt.

• Winkel eingeben (hier 45.0).

• Constrain to relative/absolute angle wählen.

•         Draw Constrained LineString wählen.

• Mit Shift + LinksKlick Linienzug zeichnen.

                 

Relativer oder absoluter Winkel.

Der grüne Linienzug wurde mit einem relativen und der blaue Linienzug mit einem absoluten Winkel von 45 

grad gezeichnet.

Wirkung von relativem und absolutem Winkel.
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3.5 Features markieren, verschieben, skalieren und drehen

Bevor Features verändert werden können, müssen sie markiert werden und der Layer editierbar sein 

(S. 31)!

                   Ganzes Feature markieren.

                   Teil einer Geometry Collection (S. 25) selektieren.

                   Ein Loch (hole) markieren.

Genau ein Feature markieren.

                    Feature verschieben.

Feature skalieren (vergrößern oder verkleinern). Mit Shift + LinksDruck wird proportional in x-

                        und y-Richtung skaliert.

• Feature drehen

• Ein oder mehrere Features markieren.

• Funktion Rotate Selected Item          wählen.

• Die Shift-Taste festhalten (Cursor wird zum Kreuz) und den Drehpunkt mit LinksKlick wählen.

• Shift-Taste loslassen und Feature mit LinksDruck drehen.
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3.6 Mehrere Features zusammenfassen (Geometry Collection)

Es können die Geometrien mehrerer Features zu einer logischen Einheit zusammengefasst werden. Hierbei 

müssen sich die Features auf einem Layer befinden. 

Achtung: Beim Zusammenfassen gehen die Sachdaten (S. 43) der Features verloren.

• Features, die zusammengefasst werden sollen, mit Shift +          markieren.

• RechtsKlick auf grafisches Fenster. 

• Im Kontextmenü: Combine selected features.

3.6.1 Features auflösen

• Geometry Collection mit          markieren.

• RechtsKlick auf grafisches Fenster.

• Im Kontextmenü: Explode Selected Features.
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3.7 Knoten (vertex, vertices) bearbeiten

Knoten (vertex) zu einem Feature hinzufügen

• Feature markieren.

• Funktion Knoten hinzufügen wählen.

• Mit LinksKlick Knoten auf Liniensegment einfügen.

                     Knoten löschen

• Feature(s) markieren.

• Funktion Knoten löschen wählen.

• Mit LinksKlick Knoten löschen.

                     Knoten verschieben

• Feature markieren.

• Funktion Knoten verschieben wählen.

• Mit LinksDruck Knoten verschieben.

                     Knoten zusammenfassen

• Mit LinksDruck ein Rechteck um die Knoten ziehen, die zusammengefasst werden sollen.

                      Zwei markierte Knoten zusammenfassen

• Feature markieren (Funktion arbeitet nur mit einem Feature!).

• Werkzeug wählen und mit LinksDruck Rahmen um beide Knoten ziehen.

• Shift-Taste drücken und auf den Zielknoten innerhalb des Rahmens klicken.

Knoten unter Bedingungen verschieben.

 Die Bedingen werden in der Editing Toolbox unter Options... unter dem Reiter 

Constraints festgelegt (siehe Seite 22).

• Feature markieren.

• Funktion Constrained Move Vertex auswählen.

• Den Knoten mit dem Cursor-Kreuze fangen und mit Shift +  LinksDruck den Knoten 

verschieben. 

• Hinweis: Wird die Shift-Taste nicht gedrückt, haben die eingestellten Bedingungen keine 

Wirkung.
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3.8 Linienzug (LineString) teilen

Linienzug teilen

• Feature markieren.

• Mit LinksKlick Linienzug teilen.

Linienzüge die sich schneiden an Schnittpunkt teilen

• Beide Linienzüge markieren.

• Mit LinksKlick auf Schnittpunkt klicken.

3.9 Bemerkungen

Bemerkungen ins Graphische Fenster schreiben. Die Bemerkungen werden auf dem Layer

Notes unter der Kategorie System gespeichert und unabhängig von einem markierten

Feature angelegt.
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4 Kategorien und Layer

4.1 Allgemeines

Layer sind Ebenen zur Darstellung von Features  (S.  17,  Vektorlayer) oder Rasterdaten (S.  35). OpenJUMP 

kennt  verschiedene  Arten  von  Layer-Typen  (Vektorlayer,  Datenbank-Layer,  MrSID-Layer,  Image-Layer, 

Rasterlayer, WMS-Layer). Hier werden nur der Vektorlayer, der Rasterlayer und der WMS-Layer vorgestellt. 

Die linke Seite des Projektfensters zeigt eine Übersicht aller vorhandenen Layer im Projekt. Layer können 

unter  Kategorien (category;  z.B.:  Vegetation,  Verkehr,  Topographie,  Gebaeude,  Grundstuecke,  u.s.w) 

zusammengefasst  werden.  Durch  geschickte  Auswahl  von  Layernamen  kann  schon  ein  einfaches 

Informationssystem erstellt werden. Im unteren Beispiel werden alle Layer mit einem Häkchen angezeigt.  Alle 

anderen Layer sind ausgeschaltet. Wurde der Layer mit Color Theming (S. 48) bearbeitet, kann eine Legende 

zum Layer durch LinksKlick auf das Schaltsymbol des Layers angezeigt werden.

                                           
Kategorien, Layer und Legende.
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4.2 Kategorien

Für eine sinnvolle Strukturierung können Layer unter Kategorien zusammengefasst werden. 

Mit  File>New>Category  kann eine neue Kategorie angelegt werden. Die neu erstellte Kategorie New 

Category  kann durch Doppel-LinksKlick umbenannt werden.

      Neue Kategorie hinzufügen.

                                                                                          

                                                                   Neuen Layer hinzufügen.                                            

                                                                                                                                                               Markierte Kategorie löschen.

Durch RechtsKlick auf die Kategorie können z.B. neue Layer hinzugefügt werden (Add A New Layer) oder 

Dateien  geladen  werden  (Load  Dataset(s)...).  Mit  Remove  Selected  Categories kann  die  Kategorie 

gelöscht werden. Die Layer der gelöschten Kategorie werden dann in die Kategorie Working verschoben.

Mit   Set Category Visibility...  können alle Layer der Kategorie sichtbar oder unsichtbar gemacht werden. 

Außerdem können die Kategorien in der Hierarchie verschoben werden (Move Category...).
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4.3 Vektorlayer

Vektorlayer ...

• ... haben einen Namen.

• ... können kopiert, ausgeschnitten, gelöscht, eingefügt und in der Hierarchie verschoben werden.

• ... können zu Kategorien (category) zusammengefasst werden.

• ... können in einer Datei oder Datenbank gesichert werden.

• ... haben eine farbliche Darstellung (Rendering, S. 46).

• ... können in Abhängigkeit von Feature-Attributen verschiedenartig dargestellt werden 

    (Thematische Darstellung, S. 48, Beschriftung, S. 51).

• ... haben ein Attributschema 

   (siehe Schema erstellen und bearbeiten, S. 44, und Sachdaten bearbeiten, S. 45).

Mit RechtsDruck auf die gewünschte Kategorie können u.a. Vektorlayer, Rasterlayer (S. 35), 

WMS-Layer (S. 38) und Kategorien (S. 29) erstellt werden.

                                                                  

        

        

                                   Layer- und Kategorien  verwalten.
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Mit RechtsKlick auf den Layernamen können spezielle Layereigenschaften bearbeitet werden.

RechtsKlick auf Layername.

                                             

Editable: Um einen Layer bearbeiten zu können, muss er editierbar sein! Wird ein Layer editierbar gemacht, 

wird die Editing Toolbox eingeschaltet und der Layername wird in rot dargestellt..

Selectable: Items können selektiert werden.

Remove Selected Layers: Markierte Layer löschen.

Layer Properties...: Layereigenschaften anzeigen.

Zoom To Layer: Den gesamten Layer anzeigen.

View / Edit Attributes: Layerattribut ansehen oder ändern (S. 45).

Schema: Schema für Attribute ansehen oder ändern (S. 44)

Style: Layerdarstellung ändern (S. 46).

Database: Datenbanklayer bearbeiten.

Save Selected Datasets: Alle markierten Layer in Datei sichern. Achtung: Nur bereits gespeicherte Layer 

können hiermit gesichert werden!

Save Dataset As...: Layer in Datei oder in PostGIS-Tabelle (mit PlugIn, S. 75) speichern.
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Move Layer Up: Layer nach oben verschieben. Höhere Priorität für Darstellung.

Move Layer Down: Layer nach unten verschieben. Niedrigere Priorität für Darstellung.

Cut Selected Layers: Markierte Layer ausschneiden.

Copy Selected Layers: Markierte Layer kopieren.

Add New Features: Geometrien im Well-Known Textformat (WKT, S. 83) hinzufügen.

Paste Items: Kopierte Items einfügen.

Delete All Features: Alle Features auf Layer löschen.

Toggle Visibility: Sichtbar/unsichtbar machen.

Select Current Layer Items: Alle Items markieren.
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4.3.1 Vektorlayer sichern (Save Dataset As...)

Jeder editierte Vektorlayer muss einzeln gesichert werden! Es stehen verschiedene Formate zur Verfügung 

(JUMP GML,  GML 2.0,  FME GML,  WKT,  ESRI Shapefile,  PostGIS Table), die mit Hilfe der Auswahlliste 

hinter  Format: ausgewählt  werden  müssen.  Hier  wird  nur  das  JUMP GML und  das  PostGIS Format 

behandelt. 

Mit Save Dataset As... (RechtsKlick auf den Layer) wird der Layer gesichert. Die Datei bekommt bei dem 

JUMP GML (Geography Mark-Up Language) Format automatisch den Suffix .jml.

Layer im JUMP GML Format sichern.

Hinweis: Dateien im JUMP GML Format oder PostGIS Format enthalten nur Geometrien und die Sachdaten. 

Es werden keine Informationen über die Ausgestaltung des Layers gespeichert. Diese Informationen stehen 

in der Projektdatei (S. 40 )!

Achtung: Dateien im  WKT-Format (Well Known Text, S.  83) enthalten  nur Geometrien! Die  Sachdaten 

(Attributwerte) werden hier nicht gespeichert!
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Wurden Layer mindestens einmal gesichert,  so können diese Layer in einem Rutsch gesichert  werden. 

Hierzu  werden  die  zu  sichernden  Layer  markiert.  Dann  mit  RechtsKlick auf  einen  der  Layer  und  mit 

Save Selected Datasets  die markierten Layer sichern.

Markierte Layer sichern.

4.3.2 Datensätze laden (Open File...)

Mit  File>Open File... können Datensätze in bestimmten Formaten geladen werden. Das Format kann im 

unteren Auswahlfenster  (Files  of  Type:)  eingestellt  werden.  Die  Datensätze  werden  als  Layer unter  der 

markierten Kategorie eingefügt. Alle markierten Dateien im Auswahlfenster werden geladen.

Die Datei Baeume.jml laden.
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4.4 Rasterlayer

Mit File>Open>Sextante Raster Image können Rasterdaten geladen und georeferenziert  werden. 

Unterstützt werden die Formate GIF (Graphics Interchange Format), TIFF (Tag Image File Format), JPG 

(Joint Photographic Experts Group)  und PNG (Portable Network Graphics). Liegt ein Worldfile zu der 

Rasterdatei vor, wird die Datei anhand der Informationen im Worldfile georeferenziert. Liegt kein Worldfile 

vor, wird die Rasterdatei über die linke untere und rechte obere Ecke über Passpunkte georeferenziert und 

dann ein Worldfile erstellt.

Es ist sinnvoll, eine neue Kategorie (S. 29) im unteren Bereich der Layerstruktur anzulegen (hier Raster), 

damit der Rasterlayer die Vektorlayer nicht überdeckt.

Rasterdatei laden

Liegt kein Worldfile vor, müssen die Passpunkte der linken unteren und rechten oberen Ecke in den 

Textfeldern eingegeben werden: 

MinX (West coordinate) = Minimaler Rechtswert; linke untere Ecke;               

MaxX: (East coordinate) = Maximaler Rechtswert; rechte obere Ecke;

MinY: (South coordinate) = Minimaler Hochwert; linke untere Ecke;

MaxY: (North coordinate) = Maximaler Hochwert; rechte obere Ecke;

Nach Finish wird das Bild georeferenziert und ein Worldfile im Bildverzeichnis angelegt!
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Hier wurde  GeoCity „beflogen“ und aus dem Luftbild ein  Orthofoto erstellt. Der Rasterlayer  OrthoPhotoGC 

liegt unter der Kategorie Raster. Die darüber liegenden Layer werden dadurch nicht überdeckt, sind allerdings 

hier ausgeschaltet.

Orthofoto von GeoCity auf einem Rasterlayer.

Die Vektorlayer überdecken den Rasterlayer.

Das Orthofoto kann als Grundlage für die Digitalisierung bestimmter Objekte dienen. Hierbei ist darauf zu 

achten, dass der Rasterlayer unterhalb der Vektorlayer liegt.
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Durch  RechtsKlick auf  den  Rasterlayer  können  bestimmte  Funktionen  des  Rasterlayers  angesprochen 

werden:

Rechtsklick auf Rasterlayer.

Toggle Raster Image Visibility: Sichtbarkeit schalten.

Change Raster Image Properties: Bildeigenschaften verändern.

Extract Selected Part Of Image...: Mit         selektiertes Teilbild (Auswahlrahmen) auf neuen Layer legen.

Save RasterImage As Image...: Bild in Datei speichern.

Zoom To Raster Image: Auf maximale Ausdehnung des Rasterlayers zoomen.

Warp Image To Fence...: Bild in Auswahlrahmen einpassen.

Export Envelope As Geometry...: Ein Polygon (Rahmen) um das Bild legen. Hinweis: Es wird ein neuer 

Layer mit dem Polygon angelegt.

Move Layer Up...: Layer innerhalb der Kategorie nach oben verschieben.

Move Layer Down...: Layer innerhalb der Kategorie nach unten verschieben.

Cut Selected Raster Image Layers: Rasterlayer kopieren und löschen.

Copy Selected Image Layers: Rasterlayer kopieren.

Paste Raster Image Layers: Kopierte Rasterlayer einfügen (Kategorie vorher markieren)!

Remove Selected Raster Image Layers: Rasterlayer löschen.
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4.5 WMS-Layer

Die von einem WMS-Server (Web Map Service) zur Verfügung gestellten Daten können in  OpenJUMP auf 

einem Layer dargestellt werden. Dieser Layer dient nur zur Darstellung der  WMS-Daten und hat nicht die 

Eigenschaften eines Vektorlayers. Es kann z.B. auf diesem Layer nicht gezeichnet werden. Dieser Layer kann 

aber als Grundlage zur Erweiterung des Informationssystems dienen, indem man z.B. durch Vektorisierung 

neue Geometrien erzeugt und mit Attributen verknüpft. Über File>Open>WMS Layer wird die URL (Uniform 

Resource Locator) des WMS-Servers eingegeben. Die URL des WMS-Servers für GeoCity lautet:

http://geo.hcu-hamburg.de:8081/cgi-bin/mapserv.exe?map=/mapserver/wms/www/geocity.map

Der  WMS-Server kann verschiedene  WMS-Layer anbieten, die man in dem Fenster  Choose WMS Layers 

auswählen kann.

Achtung: Möchte man die WMS-Layer auch in OpenJUMP auf verschiedenen Layern darstellen, muss man 

diesen Vorgang (File>Open>WMS Layer) für jeden WMS-Layer wiederholen!

             URL des WMS-Servers eingeben.                                                        WMS-Layer wählen.     

                                                

Der  WMS-Server  kann  die  Rasterdaten  in  unterschiedlichen  Koordinaten-Referenzsystemen  (Coordinate 

Reference System; CRS) schicken. Für die Darstellung muss ein entsprechendes System gewählt werden. 

Hierbei werden die Systeme nach der EPSG-Notation angegeben (European Petroleum Survey Group).

Mit  Finish wird  die  Auswahl  beendet.  Es  kann 

allerdings passieren, dass das Grafikfenster leer bleibt. 

Mit einem RechtsKlick auf den WMS-Layer und Zoom 

to WMS layer kann dann auf einen markierten Layer 

gezoomt  werden.  Je  nach  Auslastung  des  WMS-

Servers kann es einige Sekunden dauern, bis das Bild 

aufgebaut wird.

                             Koordinaten-Referenzsystem wählen.
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In  unserem  Beispiel  sind  zwei  Layer  vorhanden,  auf  denen die  Grafiken  des  WMS-Servers  dargestellt 

werden.  Allerdings  ist  die  Bounding  Box,  die  dieser  WMS-Server  liefert,  für  beide  Layer  identisch.  Mit 

RechtsKlick auf einen Layer kann dann mit  Zoom to WMS layer  auf die Bounding Box des  WMS-Layers 

gezoomt werden. Eine Bounding Box definiert einen Rahmen für einen WMS-Layer. 

Nach Zoom to WMS layer.
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5 Projekte

5.1 Allgemeines

In einer Projektdatei werden die Kategorien- und Layerstrukturen, die Verweise (Pfade) zu den gesicherten 

Datensätzen der Layer und deren Ausgestaltung (z.B. Farbe, Linienstärke, Beschriftung) gespeichert. Neue 

Vektorlayer  müssen  zuerst  gesichert  werden  (S.  33),  damit  der  Verweis  in  der  Projektdatei  gespeichert 

werden kann! Sonst erscheint eine Warnung in der linken Seite der Statusleiste. Die Verweise zu Raster- und 

WMS-Layer werden ohne separate Sicherung übernommen. Eine Projektdatei hat den Suffix .jmp.

5.2 Neues Projekt erstellen (New Project)

Mit  File>New>New Project oder mit       aus der Werkzeugleiste, kann ein neues Projektfenster erzeugt 

werden. Das neue Projektfenster mit  den Standardkategorien  Working und  System bekommt den Namen 

Project und eine laufende Nummer. 

Ein neues, leeres Projektfenster.
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5.3 Projekt sichern (Save Project, Save Project As...)

Wird ein neues Projekt (S. 40) mit File>Save Project gesichert, erscheint ein Dialogfenster zur Eingabe des 

Namens der Projektdatei. Der Suffix .jmp der Projektdatei wird automatisch vergeben. Es müssen zuvor alle 

Vektorlayer gesichert werden (S. 33), sonst erscheint eine Warnung in der Statuszeile. 

Wurde  ein  bestehendes  Projekt  mit  File>Open  Project... geöffnet  und  anschließend  gespeichert,  so 

erscheint  kein  Dialogfenster.  Mit   File>Save Project As... kann das Projekt  unter einem neuen Namen 

gesichert werden.

Projekt sichern.
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5.4 Projekt öffnen (Open Project...)

Mit  File>Open Project...  kann ein bestehendes Projekt  (S.  40) geöffnet werden. Im Dialogfenster werden 

nur die Dateien mit dem Suffix  .jmp angezeigt. Es können mehrere Projekte geöffnet werden. Unter dem 

Menüpunkt  Window  kann zwischen den Projektfenstern gewechselt werden.

Projekt öffnen.
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6 Sachdaten

6.1 Allgemeines

Es gibt verschiedene Methoden, Sachdaten in ein Projekt zu integrieren:

1. Durch direkte Eingabe in OpenJUMP. Hierzu müssen Geometriedaten vorliegen 

(siehe Geometrien, S. 9)

2. Durch Import von Dateien, die in einem bestimmten Format beschrieben sind. OpenJUMP unterstützt 

folgende Formate:

a) Das JUMP GML Format (.jml), welches ein einfaches GML-Format ist.

b) Das GML 2.0 Format.

c) ESRI Shapefile.

3. Durch Laden einer Datenbanktabelle im PostGIS Format (S. 75).

Sachdaten in Tabellenform zu den Grundstücken.
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6.2 Schema erstellen und bearbeiten

Um Sachdaten mit Geometrien verknüpfen zu können, muss zuerst für den Layer ein sogenanntes Schema 

erstellt werden. Dadurch werden die nicht-räumlichen Attribute (non-spatial attributes) der Features definiert.

 

Beispiel: Auf einem Layer werden Grundstücke dargestellt. Möchte man die  Namen der Eigentümer, den 

Wert oder z.B. die  Fläche   der Grundstücke erfassen, so muss man die Attribute zuvor in einem Schema 

vereinbaren.

Dieses Schema gilt dann für alle Features auf dem Layer. Daher ist es bei der Modellierung eines GIS wichtig, 

die Layer bzw. deren Schema so zu definieren, dass gleichartige Objekte in einem Layer erfasst  werden 

können. Es ist nicht sinnvoll, z.B. Grundstücke und Bäume auf einem Layer zu erfassen, weil Grundstücke  

und Bäume unterschiedliche Attribute haben. 

Jedem  Attribut, auch  Feld (Field) genannt,  wird ein bestimmter  Datentyp (Data Type) zugeordnet, wobei 

OpenJUMP den Datentyp  Integer (ganze Zahl),   Double (Dezimalzahl),  String (Text),  Date (Datum) und 

Geometry kennt. Das Attribut GEOMETRY ist in jedem Schema vorhanden.

Achtung: Der Datentyp Object wird hier nicht verwendet!

Mit RechtsKlick auf den Layernamen erscheint ein Pulldown-Menü. Mit  View/Edit Schema... kann das 

Schema bearbeiten werden. Mit Copy Schema / Paste Schema kann das Schema von einem Layer auf einen 

anderen Layer übertragen werden. Hierfür muss der entsprechende Layer editierbar sein!

                                           

        Schema für den Layer „Wohngebiet“ mit den Attributen GEOMETRY, Vorname, Nachname und Flaeche.
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6.3 Sachdaten (Attributwerte) bearbeiten 

Wurde ein  Schema für  einen Layer erstellt,  können die  Attribute  der  Features  eingegeben werden.  Mit 

RechtsKlick auf den Layernamen erscheint ein Pulldown-Menü. Mit                                       können die 

Attribute  bearbeiten  werden.  Der  Layer  muss  zur  Bearbeitung  der  Attributwerte  editierbar  sein!  Die 

Betrachtung ist aber immer möglich.

Die Werkzeugleiste des Attribut-Fensters bietet Funktionen zum Zoomen und Identifizieren von Features, 

deren Zeilen in der Tabelle markiert wurden. Möchte man z.B. wissen, welches Grundstück Klara Fall gehört, 

markiert  man einfach die Zeile von Klara Fall. Durch LinksKlick auf die Lupe        wird auf das Grundstück 

gezoomt und mit einem weiteren LinksKlick auf die  Taschenlampe          kurzzeitig hervorgehoben.   

Um die Funktionen der Werkzeugleiste nutzen zu können, muss eine oder mehrere  Zeilen in der Tabelle 

markiert sein.

                                      

Attributtabelle des Layers „Wohngebiet“.

Die Geometriedaten der markierten Zeile kann  man sich mit  dem Info-Knopf         der Attributtabelle 

anzeigen lassen. Man kann zwischen den Formaten WKT (Well-Known Text, S. 83), GML (Geography Mark-

Up Language) und dem CL-Format (Koordinatenliste) wählen. 

                    

Geometriedaten im Well-Known Textformat (WKT).
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7 Layerdarstellung (Styles)

Die Darstellung eines Layers,  und somit  der  Features auf  diesem Layer, kann über das  Change Styles 

Fenster  verändert  werden,  das  über den Knopf      aktiviert  wird.  Hierfür  muss  der  Layer markiert  sein  

(LinksKlick auf den Layer), aber nicht unbedingt editierbar sein. 

Es gibt fünf Möglichkeiten zur Bearbeitung: Rendering (Allgemeine Darstellung), Scale (Maßstabsabhängige 

Darstellung),  Colour  Theming (Thematische  Darstellung),  Labels (Beschriftung)  und  Decorations 

(Anfangs-/Endpunkt Darstellung).

7.1 Allgemeine Darstellung (Rendering)

Unter dem Reiter Rendering kann Folgendes eingestellt werden:

• Die Farbe der Linien und Flächen.

• Das Füllmuster von Flächen (Fill pattern).

• Die Strichlierung der Linien (Line pattern).

• Die Linienbreite (Line width).

• Die Transparenz der Farben (Transparency).

• Die Größe der Knoten (Vertices Size).

Der Stadtpark soll hellgrün dargestellt werden.
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7.2 Maßstab (Scale)

Hinter Current Scale: wird der annähernde Kartenmaßstab angezeigt. 

Hinter  Smallest/Largest  Scale kann ein  Intervall  für  die  Sichtbarkeit  des  Layers  eingestellt  werden. Im 

unteren Beispiel wird der Layer  GebaeudePrivat nur angezeigt, wenn der Maßstab zwischen 1:1000 und 

1:2000 liegt. Dazu muss das Häkchen vor  Only show layer when scale is between:  gesetzt sein.

Die Gebäude werden nicht angezeigt, da der Maßstab größer als 1:1000 ist (1:542).
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7.3 Thematische Darstellung (Colour Theming)

7.3.1 Allgemeines

Will  man eine thematische Karte  erstellen,  müssen vorher  Attribute (Attributwerte)  für  die Features des 

Layers zur Verfügung stehen (S. 44). Die Attributwerte können direkt in eine Farbe umgesetzt werden (jeder 

Attributwert steht für eine Farbe), oder es können Attribut-Intervalle dargestellt werden.

7.3.2 Direkte Darstellung (Unique value)

In  diesem  Beispiel  haben  die  Features  des  Layers  Landwirtschaft das  Attribut  Nutzungsart mit  den 

Attributwerten Hof, Acker, Wald, Getreide und Grünland. 

Das Farbschema kann allgemein mit Colour Scheme oder durch LinksKlick auf die Attributfarbe eingestellt 

werden. Sollen bei identischen Attributwerten gleiche Farben erscheinen, muss bei  Classification Method 

Unique Value eingestellt werden. Unterhalb des Layernamens im Layer-Übersichtsfenster kann die Legende 

zur thematischen Darstellung durch LinksKlick auf das Schaltsymbol angezeigt werden.

            

Thematische Darstellung von Nutzungsarten mit Beschriftung (Label).
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Durch LinksKlick auf eine Farbe in der Spalte Attribute... und Auswahl von Custom (Schiebebalken ganz 

nach oben schieben), kann für jedes Attribut ein individuelles Aussehen eingestellt werden.

Individuelle Darstellung für jedes Attribut
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7.3.3 Intervall-Darstellung (Equal Interval)

Bestehen die Attributwerte aus numerischen Daten (Integer, Double) und möchte man Intervalle thematisch 

darstellen,  so muss für  Classification Method Equal Interval,  Quantile /  Equal Number,  Mean Standard 

Deviation,  Maximal  Breaks oder  Jenks  Optimal  Method ausgewählt  werden..  In  Abhängigkeit  von  der 

Berechnungsmethode (hier  Equal  Interval)  und  Range count, werden  dann die  Intervalle  berechnet  und 

farblich  dargestellt.  In  diesem Beispiel  gibt  es zu jedem Baum einen Schädigungsgrad  (Schadgrad),  der 

zwischen 0 und 100 inklusive liegt. Da Range count auf 10 eingestellt ist, ergeben sich zehn  Intervalle, die 

farblich dargestellt werden. Auf die anderen Berechnungsarten wird hier nicht näher eingegangen!

Hinweis: Bei der Intervalldarstellung in der Spalte Label ist zu beachten, dass der maximale Wert nicht zum 

Intervall gehört!

                                                                             

                                                                       

Thematische Darstellung von geschädigten Bäumen.
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7.4 Beschriftung (Labels)

Die Attributwerte der Features können als Beschriftung dargestellt werden. In unserem Beispiel werden die 

Straßen des Layers Strassen mit dem Attribut  Name beschriftet. Die Positionierung der Texte ist abhängig 

vom gewählten Ausschnitt und ist nicht direkt beeinflussbar!

Tipp: Möchte man Text an einer bestimmten Stelle platzieren, zeichnet man auf einem Hilfslayer an den 

Textpositionen Hilfslinien mit den Textattributen. Die Darstellung der Hilfslinien kann mit der Rendering-Funk-

tion (Change Styles>Rendering, S. 46) ausgeschaltet werden, indem vor Line: das Häkchen entfernt wird.

                          

Enable labeling: Text ein- und ausschalten.

Label attribute: Attribut, das dargestellt werden soll.

Vertical alignment (for points and lines): Vertikale Textausrichtung.

Horizontal alignment (for points and lines): Horizontale Textausrichtung.

Angle Attribute (Degrees): Textwinkel in grad in Abhängigkeit eines Attributs.

Height attribute: Texthöhe in Abhängigkeit eines Attributs.

Height: Texthöhe.

Scale labels with the zoom level: Schrifthöhe in Abhängigkeit des Zoom-Faktors.

Hide labels when: Scale is below 1:X Text ab gewähltem Maßstab ein- und ausblenden.

Hide overlapping labels: Überlagernde Texte ein- und ausblenden.

               

Beschriftung der Straßen von GeoCity mit Hilfe von Labels.
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7.5 Anfangs- und Endsymbol (Decorations)

Mit Hilfe von Decorations kann ein Anfangs- und Endsymbol einer Linie festgelegt werden. Die ausgewählten 

Symbole müssen vom linken Teilfenster ins rechte Teilfenster übertragen werden, um zur Anwendung zu 

kommen. Hier wurden die Gebäude des Gewerbegebietes beschriftet. Dazu wurde ein Layer  Beschreibung 

mit den Linien der Pfeile und den Beschreibungen angelegt. Es ist darauf zu achten, in welche Richtung die 

Linien gezogen werden, weil es Start- und Endsymbole gibt. Die Startpunkte der Linien bekommen hier ein 

Pfeilsymbol  und  die  Endpunkte  bekommen  hier  ein  Federsymbol.  In  Kombination  mit  der  Beschriftung 

(Labels), können so Informationen zu den Gebäuden dargestellt werden.

               

Linien mit „Start-Arrow-Solid-Narrow“ und „End-Feathers“ kombiniert mit einer Beschriftung (Labels).
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8 Räumliche Analysen (Analysis)

8.1 Allgemeines

OpenJUMP verfügt  über  eine  Vielzahl  von  räumlichen  Analysemöglichkeiten,  die  über  Tools>Analysis 

aufgerufen werden können:

• Buffer (Saum, Distanzbereich)

• Schnittmenge (Intersect, Overlay)

• Vereinigungsmenge (Union)

• Differenz (A-B), (B-A), symmetrisch

Unter Abfragen (Queries) sind  Abfragemöglichkeiten beschrieben (S. 65). 

GeoCity wird analysiert.
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8.2 Puffer (Buffer)

8.2.1 Allgemeines

Mit Hilfe von Tools>Analysis>Buffer... kann ein Puffer (Pufferzone) um alle Geometrien eines Layers  gelegt 

werden. Es entstehen neue Flächen, die auf einem neuen Layer unter der Kategorie Result abgelegt werden. 

Der neue Layer bekommt den Namen Buffer-SourceLayer, wobei SourceLayer der Layername des Ausgangs-

layers ist (z.B. Buffer-Hafenstrasse). Bei einem Punkt entsteht z.B. nach dem „Puffern“ eine Kreisfläche um 

den Punkt mit dem Radius des Pufferabstands (Buffer Distance). Ein Linienzug wird um einen zu bestim-

menden Abstand verbreitert und als neue Fläche dargestellt. Ein Polygon wird um den Pufferabstand vergrö-

ßert. Die ursprüngliche Geometrie wird nicht verändert! Die Puffer-Funktion bezieht sich in OpenJUMP immer 

auf alle Geometrien, die auf dem Layer liegen. Die neue(n) Fläche(n) kann man für weitere Analysen nutzen. 

Liegen numerische Attribute vor, kann bei Aktivierung von Get distance from attribute value jedes Feature 

individuell gepuffert werden.

8.2.2 Puffer um einen Punkt

Die Klärgruben im Süden von GeoCity sind bei Windstille in einem Radius von ca. 300 m zu riechen. Welche 

Bereiche der Stadt sind betroffen? Hierzu legen wir auf einen neuen Layer (HP_Klaergruben) zwei Hilfspunkte 

in die Mitte der Klärgruben und bilden Pufferzonen in einem Abstand (Fixed Distance)  von 300 um die 

Punkte. Das Ergebnis steht auf dem Layer Buffer-HP_Klaergruben unter der Kategorie Result. 

                                                           Hier stinkt es gewaltig!
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8.2.3 Puffer um einen Linienzug

Die Hafenstraße soll auf 20 m verbreitert werden. Dazu legen wir einen Buffer im Abstand  von 10 um den Li -

nienzug der Straße. Es entsteht ein neuer Layer (Buffer-Hafenstrasse) unter der Kategorie Result,  auf dem 

die  verbreiterte Hafenstraße dargestellt wird. Im Buffer-Dialogfenster (Advanced Options) kann unter 

End Cap Style die Ausgestaltung der Anfangs-/Endpunkte eingestellt werden (Round, Square, Flat). Ist 

Preserve Attributes gewählt, werden die Attribute der Features des Ausgangslayers auf die 

Buffer-Features übertragen.  

 

Round                                                   Square                                                   Flat

Die verbreiterte Hafenstraße.
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8.2.4 Puffer um ein Polygon

Der Teich im Stadtpark soll um 25 m verbreitert werden. Welche Bäume müssen gefällt werden? Die neue 

Pufferzone (Buffer-Teich) kann zu weiteren Verschneidungen mit dem Layer der Bäume (Baeume) genutzt 

werden. Mit  Tools>Analysis>Overlay... können die Bäume gefunden werden, die dem neuen Teich weichen 

müssten (S. 57).

Der verbreiterte Teich im Stadtpark.
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8.3 Schnittmenge

8.3.1 Overlay

Mit  Tools>Analysis>Overlay... wird die  Schnittmenge zweier (oder mehrerer) Geometrien bestimmt. Wir 

können jetzt in unserem Beispiel „Hafenstraßenverbreiterung“ (siehe Puffer um einen Linienzug,  S.  55) die 

Buffer-Fläche mit den Grundstücken des Wohngebietes (Wohngebiet) verschneiden. Die Schnittmenge wird 

unter der Kategorie Result auf einen neuen Layer (Overlay) gelegt. Er zeigt uns die Teile der  Grundstücke, 

die für die Erweiterung benötigt werden. Mit dem View / Edit Attributes Knopf          kann man dann z.B. alle 

Eigentümer sehen, die von der Baumaßnahme betroffen sind. Dazu muss in dem Overlay-Dialogfenster 

Transfer attributes from first layer markiert sein.

                         

                             

Schnittmenge (braune Flächen) aus  „Wohngebiet“ und „Buffer-HafenStrasse“.

HCU Hamburg, Geomatik, Uwe Dallüge 57

Betroffene 
Eigentümer



8 OpenJUMP 1.6 Tutorial   (Grundlagen)

8.3.2 Intersection

Mit  Tools>Analysis>Geometry  Functions...>Intersection kann  die  Schnittmenge  zweier  Layer  gebildet 

werden (Source und  Mask). Im Gegensatz zu  Tools>Analysis>Two layers>Overlay..., darf der Mask-Layer 

nur  eine Geometrie enthalten. Falls es eine Lösung gibt, wird ein neuer Layer unter der Kategorie  Result 

angelegt. Die Attribute des Source-Layers werden auf den Ergebnislayer übertragen. Wir möchten in unserem 

Beispiel  alle  Bäume  herausfinden,  die  im  Stadtpark  von  GeoCity stehen.  Als  Source-Layer  wählen  wir 

Baeume und als Mask-Layer Stadtpark. Der Ergebnislayer Baeume-Intersection enthält nach Ausführung der 

Funktion Intersection nur die Bäume mit Attributen, die im Stadtpark stehen.

Nur die  Bäume im Stadtpark auf dem Layer Baeume-Intersection.
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8.4 Vereinigungsmenge (Union)

8.4.1 Union mit einem Layer

Mit  Tools>Analysis>Union/Dissolve/Merge können  Geometrien  auf  einem  Layer,  zu  einer  Geometrie 

vereinigt  werden.  Befinden  sich  auf  dem  Layer  Geometrien  gleichen  Typs,  z.B.  nur  Points  oder  nur 

LineStrings,  so  werden  MultiPoints  oder  MultiLineStrings  erzeugt.  Andernfalls  entsteht  eine 

GeometryCollection.  Die  neue  Geometrie  wird  unter  der  Kategorie  Result auf  einem  neuen  Layer 

Layername(union) dargestellt. Mit der Option Merge LineStrings werden zusammenhängende LineStrings 

zu einem LineString vereinigt und nicht zu einem MultiLineString.  Aggregate unused fields bewirkt  eine 

zusammenfassung oder Aufsummierung von Attributwerten.  

In unserem Beispiel „Hafenstraßenverbreiterung“ möchten wir für eine Kostenkalkulation die Gesamtfläche 

aller  Teilflächen  berechnen,  die  auf  dem  Layer  Overlay liegen  (S.  57), also  von  unseren  betroffenen 

Grundstücken. Hierzu wenden wir die Funktion Union/Dissolve/Merge auf den Layer Overlay an. Ein neuer 

Layer Overlay(union) wird unter der Kategorie Result von der Funktion erstellt. Zur Berechnung der Fläche 

muss das Schema um das Attribut Flaeche erweitert werden (S. 44). 

Mit  der  Funktion  Tools>Edit  Attributes>Calculate  Areas  and  Lengths... (S.  72) kann  dann  die 

Gesamtfläche berechnet werden. Hierfür muss der Layer Overlay(union) editierbar sein.

                      

                                                               Zusammengefasste Flächen der Teilgrundstücke auf dem Layer „Overlay(union)“.
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8.4.2 Union mit Hilfe von Attributen

Mit Tools>Analysis>Union/Dissolve/Merge können unter anderem Features über Attribute vereinigt werden. 

Außerdem ist es möglich, numerische Felder zu addieren. In unserem Beispiel wollen wir die Nutzungsarten 

des Layers Landwirtschaft zusammenfassen und die neuen Gesamtflächen und Erträge berechnen. Da nur 

die Nutzungsart „Acker“ zweimal auftaucht, werden auch nur diese beiden Flächen vereinigt und die Flächen 

und Erträge addiert (Häkchen bei „Aggregate unused fields“). Unter der Kategorie Result wird der neue 

vereinigte Layer angelegt.

    

Die Ackerflächen sind jetzt zusammengefasst. Flaeche und Ertrag wurden addiert.

60 HCU Hamburg, Geomatik, Uwe Dallüge



Räumliche Analysen (Analysis) 8

8.4.3 Union mit zwei Layer

Mit  Tools>Analysis>GeometryFunctions...>Union können, im Gegensatz zu Tools>Analysis>Union, zwei 

Layer vereinigt werden. Der Source-Layer kann n Features enthalten, der Mask-Layer nur ein Feature oder 

Item. Als Ergebnis wird jedes Feature des Source-Layers mit der Geometrie des Mask-Layers vereinigt, so 

dass wieder  n Features mit den Attributen des Source-Layers entstehen. In unserem Beispiel sehen wir 

einen Teil  des Abwassersystems von  GeoCity.  Auf  dem Layer  Zufluss befinden sich 3 Features für den 

Zufluss zur Abwasserleitung. Auf dem Layer  Abfluss befindet sich die Abflussleitung. Vereinigen wir beide 

Layer, entsteht ein neuer Layer mit 3 Features unter der Kategorie Result. Jetzt kann z.B. die Gesamtlänge 

von Zufluss und Abfluss berechnet werden (S. 72). 

Die Vereinigungen von Zufluss und Abfluss sind auf dem Layer AbwasserZufluss-Union zusammengefasst.
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8.5 Differenzen (Difference)

Mit  Tools>Analysis>Geometry  Functions... können  unter  anderem  die  Differenzen  zweier  Polygone 

(Flächen) (A – B oder B - A) berechnet werden. Diese Funktionen beziehen sich auf zwei Layer (Source und 

Mask) mit jeweils einem Feature. Bei der Differenz A - B wird, falls sich die Flächen überschneiden, von der 

Fläche  A  die  Fläche  B  „herausgeschnitten“  und eine  neue Fläche  auf  einem neuen Layer  gebildet  (gilt 

sinngemäß auch für B - A). 

In unserem  Beispiel hat Radio-GeoCity zwei neue Sendemasten bekommen (FunkA und  FunkB). Bei der 

Überlagerung der Funkwellen entstehen Interferenzen, die zu Störungen des Empfangs führen könnten. Wir 

möchten folgendes herausfinden:

1. Welches Gebiet wird durch FunkA störungsfrei abgedeckt?

2. Welches Gebiet wird durch FunkB störungsfrei abgedeckt?

      

Radio-GeoCity mit zwei neuen Funkmasten.
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Die erste Frage können wir dadurch beantworten, dass wir die Differenz A - B mit den Layern Buffer-FunkA 

und  Buffer-FunkB bilden. Dazu wählen wir im Dialogfenster  Geometry Functions für  Source Buffer-FunkA 

und für Mask Buffer-FunkB. Als Funktion (Function) wählen wir  Difference (A-B), also Source minus Mask. 

Das Ergebnis steht unter der Kategorie Result auf dem Layer Source-Function, also auf dem Layer

Buffer-FunkA-Difference (A-B). Die zweite Frage kann mit Differenz B – A gelöst werden.

Störungsfreier Empfang durch FunkA  (Differenz A-B) 

                                                                        Störungsfreier Empfang durch FunkB  (Differenz B-A) 
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8.6 Symmetrische Differenz (Symmetric Difference)

Mit  Tools>Analysis>Geometry  Functions... kann  unter  anderem die  Symmetrische  Differenz berechnet 

werden.  Diese Funktion bezieht sich auf zwei Layer (Source und Mask) mit jeweils einem Feature. Bei der 

Symmetrischen Differenz wird die Fläche auf Layer A mit der Fläche auf Layer B zusammengefasst (Union) 

und die überlappende Fläche herausgeschnitten und eine neue Fläche auf einem neuen Layer erzeugt.

In unserem  Beispiel hat Radio-GeoCity zwei neue Sendemasten bekommen (FunkA und  FunkB). Bei der 

Überlagerung der Funkwellen entstehen Interferenzen, die zu Störungen des Empfangs führen könnten. Wir 

möchten folgendes herausfinden: Welches Gebiet hat guten Empfang?

Die Frage können wir dadurch beantworten, dass wird die Symmetrische Differenz zwischen 

Buffer-FunkA und Buffer-FunkB bilden. Leider müssen wir feststellen, dass die Anwohner im Wohngebiet um 

die Hafenstraße möglicherweise schlechten Empfang haben. Mit OpenJUMP wäre das nicht passiert ;-)

                                                                               

Guter Empfang im blauen Gebiet (Symmetrische Differenz).
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9 Abfragen (Queries)

9.1 Allgemeines

Über Tools>Queries können räumliche Abfragen oder Abfragen bezüglich Attribute (Sachdaten) ausgeführt 

werden.  Wegen der  Fülle  der  Möglichkeiten,  werden hier  nur  exemplarisch einige Abfragemöglichkeiten 

vorgestellt. Räumliche Analysen finden Sie unter Räumliche Analysen (S. 53).

9.2 Räumliche Abfragen (Spatial Query...)

9.2.1 Allgemeines

Mit Tools>Queries>Spatial Query... können alle Features eines Layers (Source Layer) gefunden werden, 

die in einer räumlichen Beziehung (spatial relationship) zu einem zweiten Layer (Mask Layer) stehen. Hierbei 

kann das Ergebnis der Abfrage auf einem neuen Layer dargestellt werden, wobei die Sachdaten mit 

übernommen werden, oder das Ergebnis wird auf dem Source Layer selektiert. 

Räumliche Abfragen.

Source Layer: Layer, der die gesuchten Features enthält.

Relation: Räumliche Beziehung zwischen Source- und Mask-Layer.

Mask Layer: Layer, mit den Features, die in räumlicher Beziehung zum Source Layer stehen.

Allow Duplikates in Result: Doppelte Ergebnisse erlauben.

Complement Result: Alle Ergebnisse, die nicht zutreffen.

Create a new layer for the results: Die Ergebnisse auf einem neuen Layer ablegen.

Select features in the source layer: Die Ergebnisse werden im Source Layer selektiert.
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9.2.2 contains

Mit  contains werden diejenigen Features des  Source Layers gesucht,  die die Features des  Mask Layers 

enthalten.

In unserem Beispiel sollen alle bebauten Grundstücke des Wohngebiets mit Eigentümern gesucht werden, 

also  alle  Grundstücke  (Features)  des  Layers  Wohngebiet  (Source  Layer),  die  Features  vom  Layer 

GebaeudePrivat (Mask Layer) enthalten. Da Grundstücke gesucht werden, muss im Dialog-Fenster hinter 

Source  Layer der  Layer  Wohngebiet ausgewählt  werden.  Hinter  Relation steht  die  Verknüpfung  (hier 

contains, enthalten) und hinter Mask Layer der Layer, mit dem der Source Layer verknüpft werden soll (hier 

GebaeudePrivat). Als Ergebnis wird ein neuer Layer unter der Kategorie Result mit dem Namen SourceLayer-

Relation (hier Wohngebiet-contains) angelegt. Die Attribute werden vom Source Layer übernommen.

Alle bebauten Grundstücke (dunkel) mit Eigentümern auf dem Layer „Wohngebiet-contains“.
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9.2.3 intersects

Mit intersects werden diejenigen Features des Source Layers gesucht, die in dem Mask Layer enthalten sind, 

oder von ihm geschnitten werden. In unserem Beispiel suchen wir die Grundstücke (und damit die 

Eigentümer) des Wohngebietes, bei denen noch Empfang von Funkmast A möglich ist.

Die roten Flächen liegen teilweise oder vollständig im Kreis.
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9.2.4 overlaps

Mit  overlaps werden diejenigen Features des  Source Layers gesucht, die die Features des  Mask Layers 

überlappen.

In  unserem  Beispiel  sollen  alle  Grundstücke  des  Wohngebiets  gesucht  werden,  die  von  einer 

Straßenverbreiterung der  Hafenstraße betroffen sind.  Da Grundstücke  gesucht  werden,  muss  im Dialog-

Fenster  hinter  Source  Layer der  Layer  Wohngebiet ausgewählt  werden.  Hinter  Relation steht  die 

Verknüpfung (hier  overlaps,  überlappen) und hinter  Mask Layer der  Layer,  mit  dem der  Source Layer 

verknüpft werden soll (hier Buffer-Hafenstrasse). Als Ergebnis wird ein neuer Layer unter der Kategorie Result 

mit dem Namen SourceLayer-Relation (hier Wohngebiet-overlaps) angelegt. Die Attribute werden vom Source 

Layer übernommen.

Alle blau umrandeten Grundstücke sind von der Verbreiterung der Hafenstraße betroffen.
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9.2.5 within

Mit  within werden diejenigen Features des  Source Layers gesucht, die  innerhalb der Features des  Mask 

Layers liegen.

In unserem Beispiel sollen alle Bäume gesucht werden, die auf den Grundstücken des Wohngebiets stehen. 

Da Bäume gesucht werden, muss im Dialog-Fenster hinter  Source Layer der Layer  Baeume ausgewählt 

werden. Hinter Relation steht die Verknüpfung (hier within, innerhalb) und hinter Mask Layer der Layer, mit 

dem der Source Layer verknüpft werden soll (hier Wohngebiet). Als Ergebnis wird ein neuer Layer unter der 

Kategorie Result mit dem Namen SourceLayer-Relation (hier Baeume-within) angelegt. Die Attribute werden 

vom Source Layer übernommen.

Auf dem Layer „Baeume-within“ sind alle Bäume (blaue Schrift), die auf den Grundstücken des Wohngebiets stehen.
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9.3 Abfragen nach Attributen (Attribute Query...)

Mit  Tools>Queries>Attribute  Query... können Features eines Layers über  ihre  Attributwerte  ausgewählt 

werden. In unserem Beispiel sollen alle Grundstücke, die größer als 3000 qm sind, gesucht werden. Hinter 

Source Layer wird der Layer ausgewählt, der analysiert werden soll (hier Wohngebiet). Hinter Attribute wird 

das Attribut für den Vergleich ausgewählt (hier  Flaeche). Hinter  Relation steht der Vergleichsoperator und 

hinter  Values steht  der  Wert,  mit  dem verglichen  werden  soll.  Ist  Create  a  new layer for  the  results 

ausgewählt, wird unter der Kategorie  Result ein neuer Layer mit dem Namen des  Source Layers und dem 

Vergleichsoperator angelegt (hier Wohngebiet->=). Mit Hilfe von Labels (S. 51) können die Flächen dann mit 

ihrer Größe beschriftet werden.

Alle Grundstücke des Wohngebiets, die 3000 qm und größer sind.
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9.4 Einfache Abfragen (Simple Query)

Mit Tools>Queries>Simple Query kann der so genannte Query Builder aufgerufen werden. Hiermit können 

räumliche Abfragen und Abfragen nach Attributen durchgeführt werden. In unserem Beispiel wollen wir alle 

Grundstücke auf dem Layer Wohngebiet suchen, die der Stadt GeoCity gehören (Attribut Nachname). Unter 

Layer wird der Layer ausgewählt, auf dem die Abfrage ausgeführt werden soll. Unter  Attribute wird das 

entsprechende Attribut (hier  Nachname) ausgewählt. Unter  Function wird die entsprechende Funktion für 

den Datentyp des Attributs ausgewählt.  Hier ist  der Datentyp  String und die Funktion  trim eliminiert  alle 

Leerzeichen und Tabulatoren. Unter Operator wählen wir equals, weil alle Nachnamen gesucht werden, die 

gleich (equals) GeoCity sind (Value). Mit dem Knopf Valid wird die Abfrage ausgeführt. Wurde unter Results 

Create  a  New  Layer ausgewählt,  wird  der  Ergebnislayer  unter  der  Kategorie  Result angelegt  (hier 

Wohngebiet_GeoCity). Die Attribute des Ausgangslayers werden mit übernommen.

Alle Grundstücke, die der Stadt GeoCity gehören (hier schraffiert).
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10 Berechnungen und Statistiken

10.1 Flächen- und Längenberechnung

Mit  Tools>Edit Attributes>Calculate Area and Length... kann der Flächeninhalt von Polygonen oder die 

Länge von Linienzügen auf einem Layer berechnet werden. Hierzu muss für den Layer ein Attribut definiert 

sein, das das Ergebnis der Flächen- oder Längenberechnung aufnehmen kann (S. 44). Um die Flächen oder 

Längen berechnen zu können, muss der  Layer editierbar sein! Im unteren Beispiel werden die Flächen der 

einzelnen  Grundstücke  des  Layers  Wohngebiet berechnet.  In  dem  Dialogfenster  wird  der  Layer,  die 

Berechnungsart und das Attribut für das Ergebnis ausgewählt.

Flächenberechnung für den editierbaren Layer „Wohngebiet“.

Hinweis: Die Statistik-Funktionen (S. 73) bieten andere Möglichkeiten, Flächen und Längen zu berechnen!
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10.2 Layer-Statistiken

Mit  Tools>Statistics>Layer  Statistics...  können  Statistiken  bezüglich  der  Geometrien  eines  Layers 

angezeigt  werden.  Dazu  muss  der  Layer  markiert  und  dann  die  Funktion  aufgerufen  werden.  Hinter 

Envelope stehen die minimalen und maximalen Koordinaten des Layers. Hinter # Features steht die Anzahl 

der  Features  (hier  14  Grundstücke).  Die  Tabelle  zeigt  die  minimalen  (Min),  maximalen  (Max), 

durchschnittlichen  (Avg)  und  gesamten  (Total)  Werte  der  Punkte  (Pts),  Löcher  (Holes),  Komponenten 

(Components), Flächen (Area) und Längen (Length) an. In unserem Beispiel sehen wir, dass das kleinste 

Grundstück eine Fläche von 1218 qm hat, die größte Fläche 13800 qm und die Gesamtfläche 53637 qm 

beträgt.

Hinweis: Die  Dimension  qm  hängt  natürlich  von  der  Dimension  der  Zeicheneinheit  ab.  Da  hier  eine 

Zeicheneinheit = 1 m ist,  werden z.B. die Flächen in qm (Quadratmeter) angezeigt.

Informationen über den Layer „Wohngebiet“.
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10.3 Feature-Statistik

Mit Tools>Statistics>Feature Statistics... können Informationen zu den einzelnen Features auf einem Layer 

angezeigt werden. Hierbei wird eine neue Kategorie QA (Qualitätsanalyse) angelegt, unter der ein neuer Layer 

mit dem Namen Statistics-Layername (hier Statistics-Wohngebiet) angelegt wird. Mit       kann die Feature-

Statistik angezeigt werden. In unserem Beispiel sehen wir unter anderem die Flächen (area) und die Umfänge 

(length) der einzelnen Grundstücke.

Fläche und Umfang der Features des Layers „Wohngebiet“.

74 HCU Hamburg, Geomatik, Uwe Dallüge

Kategorie QA
mit neu 
erstelltem Layer.



Anbindung an eine PostgreSQL / PostGIS Datenbank 11

11 Anbindung an eine PostgreSQL / PostGIS Datenbank 

OpenJUMP kann  Tabellen  (Relationen)  und  Sichten  (Views)  mit  Geometriespalte  einer  PostgreSQL  / 

PostGIS Datenbank  lesen  und  Tabellen  schreiben.  PostgreSQL (http://www.postgresql.org/)  ist  ein 

Objektrelationales Datenbankverwaltungssystem (ORDBMS),   zu dem es eine sogenannte  PostGIS-

Erweiterung gibt  (http://postgis.refractions.net/).  Mit  Hilfe  dieser  Erweiterung  können  Geometrien  und 

Attributwerte in Tabellen gespeichert und gelesen werden. Um eine Tabelle lesen oder schreiben zu können, 

muss zuerst eine Verbindung zum Datenbankmanagementsystem aufgebaut werden. Das kann z.B. über 

File>Open...>Data Store Layer>Connection Manager         erfolgen:

                           Verbindung zum DBMS aufbauen.

Zum Aufbau der Verbindung müssen folgende Informationen zum DBMS bekannt sein:

• Die IP-Adresse des PostgreSQL-Servers (Server); hier localhost.

• Die Portnummer (Port, normalerweise 5432).

• Den Datenbanknamen (Database).

• Den Tabellennamen (Table).

• Den Benutzernamen und das Passwort (User, Password).

Hinter Name steht der Aliasname der Verbindung.
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Mit dem Programm pgAdmin III, das mit PostgreSQL installiert wird, kann die Datenbank administriert und 

z.B. Tabellen angesehen werden  (siehe auch PostGIS-Tutorial 1.5 (Grundlagen), 

http://sourceforge.net/projects/jump-pilot/files/Documentation/PostGIS%20Tutorial%20%28for%20external

%20Plugin%29/

Tabelle mit Geometriespalte, dargestellt mit pgAdmin III.
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11.1 Tabelle schreiben

Mit RechtsKlick auf einen Layer und Save Dataset As... kann ein Vektorlayer in eine Datenbank geschrieben 

werden.  Hierzu  muss  in  der  Save  Dataset  As-Eingabemaske hinter Format:  PostGIS  Table  (new) 

ausgewählt  werden.  Der  Name  des  Layers  steht  automatisch  hinter  Table.  Unter  Select save method 

können verschiedene Optionen ausgewählt werden, wobei hier nur die ersten beiden beschrieben werden. 

Mit Create new or replace existing table wird eine neue Tabelle in der Datenbank angelegt. Existiert bereits 

eine Tabelle gleichen Namens, kann sie nach Abfrage gelöscht werden. Diese Funktion wird meist dazu 

benutzt, wenn das Schema des Layers in  OpenJUMP geändert wurde (S. 44), oder wenn der SRID-Wert mit 

Layer>Change SRID geändert wurde. Mit  Replace all features from table kann eine bestehende Tabelle 

überschrieben werden, ohne dass sich mögliche Nebenbedingungen (Constraints) der Tabelle verändern. Es 

wird nur der Tabelleninhalt gelöscht und neu geschrieben, aber nicht das Tabellenschema verändert.

Der Layer „Bauernhof“ wird in eine PostGIS Tabelle die Datenbank  geschrieben, die hinter Connection: steht.

Hinweis: Wird eine bestehende Tabelle mit  Create new or replace existing table gelöscht, darf sie nicht 

vorher in einer Sicht (View) angesprochen werden, da es sonst kommt es zu einer Fehlermeldung kommt!
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11.2 Tabelle oder Sicht (View) lesen

Um eine Tabelle oder Sicht laden zu können, muss zuerst eine Kategorie markiert werden. Dann mit 

File>Open... den Data Store Layer anwählen und die entsprechende Verbindung (Connection) und Tabelle 

(Dataset) wählen. Der Textbereich für die Where-Klausel ist optional. Hier kann beim Laden der Tabelle mit 

einer SQL WHERE-Klausel selektiert werden, welche Datensätze geladen werden sollen. Soll eine Tabelle 

aus einem anderen Postgres-Schema geladen werden als public, so kann man hinter Dataset: mit der 

Punktnotation Schemaname.Tabellenname die entsprechende Tabelle laden.

                         

Die PostGIS Tabelle „Bauernhof“ wird gelesen.
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12 Drucken

In OpenJUMP ist es nicht möglich, die dargestellte Grafik direkt zu drucken. Die Grafik kann aber im Raster- 

(PNG, JPEG) oder Vektor-Format (Scalable Vector Graphics, SVG)  in eine Datei gespeichert - und mit ei-

nem geeigneten  Programm  (z.B.  PhotoFiltre  http://www.photofiltre.com bzw.  Inkscape  http://www.inksca-

pe.org) ausgedruckt werden. Hierbei ist das Vektorformat SVG dem Rasterformat vorzuziehen, weil es bes-

ser skalierbar ist. Um dies Funktion nutzen zu können, benötigen Sie die OpenJUMP PLUS Version!

Mit  File>Save View As>Save View as SVG wird  die Grafik  des Projekts  im  SVG-Format  gespeichert. 

Hierbei werden nur die Layer gespeichert, die auch eingeschaltet sind. Mit dem Open Source Programm 

Inkscape kann dann z.B. die Datei bearbeitet und gedruckt werden.

              GeoCity als Grafik in Inkscape.
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13 Glossar

CRS: Coordiante Reference System

EPSG: European  Petroleum  Survey  Group;  heute  OGP (Oil  &  Gas  Producers)  Surveying &  Positioning 

Committee.  www.epsg.org

Das Oil & Gas Producers Surveying and Positioning Committee pflegt und veröffentlicht Parameter und Be-

schreibungen für Koordinatenreferenzsysteme. Diese Parameter werden unter einer Kennung zusammenge-

fasst, dem Spatial Reference System Identifier (SRID). Diese Kennungen werden z.B. in OGC konformen 

Diensten (z.B. WMS) und in PostGIS verwendet und ausgewertet.

(Siehe auch OGC: „Coordinate Transformation Services“).

Beispiel: EPSG:   4326 = Geografische Koordinaten im WGS84 Bezugssystem

EPSG: 31466 = Gauß-Krüger, 2. Streifen 

EPSG: 31467 = Gauß-Krüger, 3. Streifen

EPSG: 31468 = Gauß-Krüger, 4. Streifen

Die entsprechenden  Dateien mit den Datensätzen (EPSG geodetic parameter dataset) können von der 

Seite http://www.epsg.org/ geladen werden.

Feature (Objekt): 

● Features sind abstrahierte Objekte der realen Welt.  Zum Beispiel werden Straßen als Linienzüge, 

Gebäude als Flächen oder Bäume als Punkte abstrahiert und dargestellt.

In  OpenJUMP hat jedes Feature ein räumliches Attribut (Geometrie) und keins oder mehrere nicht-

räumliche  Attribute  (non-spatial  attributs,  Fachdaten,  Sachdaten)  z.B.  Straßenname,  Eigentümer, 

Baumhöhe.

● Eine Gruppe von räumlichen Elementen, die zusammen eine Einheit der realen Welt repräsentieren. 

Oft synonym verwendet mit dem Ausdruck Objekt. Kann auch zu komplexen Features (Objekten), 

bestehend  aus  mehr  als  einer  Gruppe  von  räumlichen  Elementen,  zusammengesetzt  werden. 

(Lexikon der Geoinformatik, 2001)

● A geographic  feature is  „an abstraction of  a real  world phenomeon ...  associated with a location 

relative to Earth“. A feature has spatial attributes (polygons, points, etc.) and non-spatial attributes 

(strings, dates, numbers). (JUMP Workbench User's Guide, 2004)
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GeometryCollection: Zusammenfassung von Geometrien unterschiedlichen Typs.

GISWiki: Ein Wiki mit der Thematik "Geografische Informationssysteme (GIS)" ;  http://www.giswiki.de/ 

GML: Geography Mark-Up Language; siehe auch http://www.opengeospatial.org/ 

GNU General Public License: Lizenzierung freier Software;  http://www.fsf.org/licensing/licenses/gpl.html 

Inkscape: Editor für Vektorgrafik (Open Source); http://www.inkscape.org/ 

Item: Grafische Darstellung eines Features in OpenJUMP.

JPEG: Joint Photographic Experts Group;  Grafikformat; http://www.jpeg.org/ 

Mapserver: Entwicklungsumgebung für die Erstellung von Internet-Anwendungen mit dynamischen 

Karteninhalten;  http://mapserver.org/

OGC: Open Geospatial Consortium; http://www.opengeospatial.org/ 

Internationales Normierungsgremium für Standards und Schnittstellen von GIS und Location Based Services 

(LBS) Anwendungen. Vereinigung von Firmen und Forschungseinrichtungen.

OGP: Oil & Gas Producer; http://www.ogp.org.uk/ 

OGP Surveying and Positioning Committee: ehemals EPSG, http://www.epsg.org/ 

OpenGIS: siehe OGC;  http://www.opengeospatial.org/ 

OpenJUMP: Geografisches Informationssystem; Erweiterung von JUMP;   http://www.openjump.org/

Open Source: Quelloffenheit;   http://de.wikipedia.org/wiki/Open_source 

PNG: Portable Network Graphics; Grafikformat zur verlustfreien Speicherung

PostGIS: Erweiterung von PostgreSQL um geografische Objekte; http://postgis.refractions.net/ 

PostgreSQL: Objektrelationales Datenbankmanagementsystem;  http://www.postgresql.org/ 

Refractions Research: Kanadische Firma, die JUMP mitentwickelt hat;  http://www.refractions.net/ 
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Spatial attributes: Räumliche Attribute (Punkt, Linie, Fläche).

Spatial information: Geoinformation, Rauminformation

SRID: Spatial Reference System Identifier; Kennung für Räumliches Bezugssystem

SRS: Spatial Reference System: Räumliches Bezugssystem 

SVG: Scaleable Vector Graphics; vom W3C empfohlenes Grafikformat; http://www.w3.org/Graphics/SVG/ 

URL: Uniform Resource Locator; z.B. ein Link im Browser.

Vertex, vertices: Knoten, Eckpunkt.

Vivid Solutions: Kanadische Firma, die JUMP mitentwickelt hat;  http://www.vividsolutions.com/ 

W3C: World Wide Web Consortium;  http://www.w3.org/ 

Well-Known Binary (WKB): Binäre Repräsentationen für Geometrien, die in dem OpenGIS Dokument

„OpenGIS Simple Features Specification For SQL“ definiert sind.

Wiki: Ein  Wiki,  auch  WikiWiki und  WikiWeb genannt,  ist  eine  im  World  Wide  Web verfügbare 

Seitensammlung, die von den Benutzern nicht nur gelesen, sondern auch online geändert werden kann. Wikis 

ähneln damit Content Management Systemen. Der Name stammt von wikiwiki, dem hawaiianischen Wort für 

"schnell".  (Wikipedia, 2005)
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Well-Known Text (WKT): Textliche Darstellung von Geometrien, die in dem OpenGIS Dokument

„OpenGIS Simple Features Specification For SQL“ definiert sind. 

Ein Punkt (Point) wird z.B. als 'POINT (10 15)' dargestellt.

                                                   Geometrietypen im WKT-Format      (Quelle: OpenGIS Simple Features Specification for SQL)

WKB: siehe Well-Known Binary

WKT: siehe Well-Known Text

WMS: Web Map Service; Internet-Dienst, der auf standardisierte Anfragen standardisierte Daten zur 

Kartenbild-Darstellung liefert. Dieser Dienst ist als OGC Standard definiert.
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15 Linksammlung

Inkscape http://www.inkscape.org/ 

JUMP http://www.vividsolutions.com/jump/

MapServer http://www.umn-mapserver.de/ 

OGP Surveying &  Positioning Committee http://www.epsg.org/ 

Open Geospatial Consortium http://www.opengeospatial.org/ 

OpenJUMP (deutsche Seite) http://www.openjump.de/

OpenJUMP (englische Seite) http://www.openjump.org/ 

PIROL, Hochschule Osnabrück http://www.al.hs-osnabrueck.de/jump-download.html

PostGIS http://postgis.refractions.net/ 

PostgreSQL http://www.postgresql.org/ 
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16 Stichwortverzeichnis
Abfragen.............................................................65

Abfragen nach Attributen....................................70

Aggregate unused fields.....................................59

Allgemeine Darstellung......................................46

Anfangs- und Endsymbol...................................52

Anfangssymbol...................................................52

Attribute Query...................................................70

Attributwerte.......................................................45

Bemerkungen.....................................................27

Beschriftung.......................................................51

Bounding Box.....................................................39

Buffer.................................................................54

category.............................................................28

Colour Scheme..................................................48

Colour Theming..................................................48

Constraints.........................................................11

contains..............................................................66

Copy Schema.....................................................44

Datentyp.............................................................44

Decorations........................................................52

Differenz A - B....................................................62

Double................................................................44

Drehen...............................................................24

Drucken..............................................................79

Editing Toolbox...................................................11

Endsymbol.........................................................52

ESRI Shapefile...................................................33

Fangmodus........................................................14

Farbe..................................................................46

Farbschema.......................................................48

Features...............................................................7

Fill pattern..........................................................46

Fläche................................................................10

Flächenberechnung............................................72

Füllmuster..........................................................46

Geometriedaten...................................................9

Geometrien..........................................................9

Geometry Collection...........................................25

Geometry Functions.....................................62, 64

Gesamtfläche.....................................................59

Gitterlinien..........................................................14

Glossar...............................................................80

GML...................................................................45

GNU General Public License................................6

Inkscape.............................................................79

Integer................................................................44

Intersection.........................................................58

IP-Adresse.........................................................75

JUMP...................................................................6

JUMP GML.........................................................33

Kategorien........................................................28f.

Kategorien und Layer.........................................28

Knoten................................................................26

Kreis mit Radius und Genauigkeit......................19

Labels.................................................................51

Längenberechnung............................................72

Layer....................................................................7

Layer View............................................................7

Layer-Statistiken.................................................73

Layerdarstellung.................................................46

Layername.........................................................10

Line pattern........................................................46

Line width...........................................................46

Linestring............................................................17

Linienbreite.........................................................46

Linienzug................................................10, 17, 27

Linksammlung....................................................85

Literaturverzeichnis............................................84

Loch.............................................................18, 24

Maßstab (Scale).................................................47

Measurement.....................................................13

Merge LineStrings..............................................59

Open Source........................................................6

OpenJUMP...........................................................6
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Options (Constraints).........................................11

Options (Dataset)..............................................12

Options (Measurement).....................................13

Options (Selection Style)...................................14

Options (Snap / Grid).........................................14

Options (Snap Vertices Tools)...........................15

Options (View / Edit)..........................................16

overlaps.............................................................68

Paste Schema...................................................44

PIROL................................................................85

Point..................................................................17

Polygon..............................................................17

Polygon anpassen.............................................18

Polygon aus geschlossenem Linienzug.............18

Polygon ausschneiden.......................................18

Portnummer.......................................................75

PostGIS...................................................9, 33, 75

PostGIS Tabelle................................................77

PostGIS-Erweiterung.........................................75

PostgreSQL...................................................9, 75

PostgreSQL / PostGIS Datenbank ...................75

Projekt.................................................................7

Projekt erstellen.................................................40

Projekt öffnen....................................................42

Projekt sichern...................................................41

Projektdatei.......................................................40

Projekte.............................................................40

Projektfenster......................................................7

Puffer.................................................................54

Punkt...........................................................10, 17

Queries..............................................................65

Rasterlayer........................................................35

Räumliche Analysen..........................................53

Refractions Research..........................................6

Rendering..........................................................46

Sachdaten............................9, 17, 33, 43, 44f., 80

Scalable Vector Graphics..................................79

Schema erstellen...............................................44

Schnittmenge....................................................57

Selection Style...................................................14

Shapefiles..........................................................12

Shortcut keys.....................................................21

Show grid...........................................................14

Show grid as dots..............................................14

Show grid as lines.............................................14

Snap / Grid........................................................14

Snap to grid.......................................................14

Snap to vertices.................................................14

Snap to vertices and lines..................................14

Snap Vertices Tools..........................................15

Snapping...........................................................14

Strichlierung.......................................................46

String.................................................................44

Styles.................................................................46

SVG...................................................................79

Symmetrische Differenz....................................64

Tabelle  lesen....................................................78

Tabelle schreiben..............................................77

Thematische Darstellung...................................48

Tipps.................................................................20

Transparency.....................................................46

Transparenz......................................................46
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This is the end.
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